Eclipse EMF build failures on ppc64 hosts

Mat Booth fedora at
Sun Mar 1 19:56:31 UTC 2009

I've updated eclipse-emf and I'm trying to build it, but it seems to
fail if the build host arch is ppc64. By chance, all the scratch
builds I've submitted were built on i586 hosts and they have all
worked perfectly. By chance, all the real builds I've submitted were
built on ppc64 hosts and they all fail with the same error.

Scratch builds succeeding on i586:

Real builds failing on ppc64:

The spec file[1] contains the following lines:

    %define eclipse_base     %{_libdir}/eclipse
    %{eclipse_base}/buildscripts/pdebuild -f org.eclipse.emf.all \
      -a "-DjavacTarget=1.5 -DjavacSource=1.5

And the error message on ppc64 builds is the following:

    /var/tmp/rpm-tmp.5hAGBF: line 31:
/usr/lib/eclipse/buildscripts/pdebuild: No such file or directory

Now, I could be wrong, but it looks to me like the RPM macro
%{_libdir} is expanding incorrectly on ppc64 hosts. (Surely it should
expand to /usr/lib64!) Is this a bug? If so, what component should I
raise the ticket for in Bugzilla?


Mat Booth

More information about the fedora-devel-list mailing list