On 08/09/07, <b class="gmail_sendername">Jonathan Underwood</b> <<a href="mailto:jonathan.underwood@gmail.com">jonathan.underwood@gmail.com</a>> wrote:<div><span class="gmail_quote"></span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Hi,<br><br>I was just trying to update  package of mine, and the main change is<br>adding the following macros to the spec file:<br><br>%define emacs_version %(pkg-config emacs --modversion)<br>%define emacs_lispdir %(pkg-config emacs --variable sitepkglispdir)
<br>%define emacs_startdir %(pkg-coonfig emacs --variable sitestartdir)<br><br>in order to determine those things at package build time (as discussed<br>previously on fedora-packaging). However, on attempting to check the
<br>changes in, I get this:<br><br>cvs diff: [12:11:28] obtained lock in /cvs/extras/rpms/emacs-vm/devel<br>Package emacs was not found in the pkg-config search path.<br>Perhaps you should add the directory containing `emacs.pc'
<br>to the PKG_CONFIG_PATH environment variable<br>No package 'emacs' found<br>error: line 31: Version required: Requires: emacs >=<br>error: query of specfile emacs-vm.spec failed, can't parse<br>Package emacs was not found in the pkg-config search path.
<br>Perhaps you should add the directory containing `emacs.pc'<br>to the PKG_CONFIG_PATH environment variable<br>No package 'emacs' found<br>error: line 31: Version required: Requires: emacs >=<br>error: query of specfile 
emacs-vm.spec failed, can't parse<br>cvs tag  -c emacs-vm--<br>? .build-8.0.3.495-1.fc8.log<br>? .build-8.0.3.495-3.fc8.log<br>? .emacs.desktop<br>? clog<br>? emacs-vm-8.0.3.495-1.fc8.src.rpm<br>? emacs-vm-8.0.3.495-3.fc8.src.rpm
<br>? vm-8.0.2-devo-482.tgz<br>? vm-8.0.3-495<br>? x86_64<br>ERROR: Tag emacs-vm-- is not in name-version-release format<br>cvs tag: Pre-tag check failed<br>cvs [tag aborted]: correct the above errors first!<br>make: *** [tag] Error 1
<br><br><br>Is it therefore not possible to call pkg-config from within a spec<br>file? Could this be fixed?<br></blockquote></div><br>I think buildsys is having a bad hair day. My builds are failing because util-linux-ng is missing as a dependency.
<br><br><a href="http://koji.fedoraproject.org/koji/getfile?taskID=152224&name=srpm.log">http://koji.fedoraproject.org/koji/getfile?taskID=152224&name=srpm.log</a><br><a href="http://koji.fedoraproject.org/koji/getfile?taskID=152224&name=root.log">
http://koji.fedoraproject.org/koji/getfile?taskID=152224&name=root.log</a><br clear="all"><br>Cheers<br>Chris<br><br>-- <br><a href="http://www.chruz.com">http://www.chruz.com</a>