[Fedora-directory-users] Database recreation, automount and performance

Rich Megginson rmeggins at redhat.com
Wed Jul 13 16:47:23 UTC 2005

Vsevolod (Simon) Ilyushchenko wrote:

> Hi,
> I'm extremely glad FDS is now freely available and almost open-source. 
> I have run into some issues when I started playing with it.
> 1. I've tried to port my OpenLDAP database to it and found that that 
> there is no automount objectclass specified by default. The automount 
> and automountInformation classes are defined in Fedora schema extensions
> that come with the openldap RPM, so not having them in FDS is a little
> weird. I had to define them myself.

The IETF LDAP community has decided to deprecated them in favor of the 
new netgroups stuff.

> 2. After a failed import I deleted the database and tried to recreate 
> it. I went first to Configuration/Data/New Root Suffix and specified 
> the base DN and the database name. Then I went to Data/<Server 
> name:389>/ New Root Object and tried to create the root entry, but got 
> this error:
> "Only the Directory Manager has the right to create the Root Entry. 
> Log in as Directory Manager to be able to perform this operation. "
> I've checked that the manager DN is specified correctly in 
> Configuration/Manager.

We don't yet have a way to set an ACI to allow users other than the 
Directory Manager (i.e. cn=Directory Manager, not the admin console 
user) to create the entry for a root suffix.  In the console, you can 
Log In As New User, and specify cn=directory manager (or whatever you 
used for your directory manager user when you performed the initial 

> I tried restarting the directory server, but that did not help. How do 
> I reinitalize it?
> 3) Finally, the Java administration console is extremely slow. I'm 
> running over an SSH connection, but my server is a 2.8 Ghz machine 
> with 512 Mb of RAM. I wonder what console performance other people 
> experience.

It's not great.  It is a huge Java/Swing application.

> Thanks - I'm looking forward to deploying FDS with Windows sync!
> Simon

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3312 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://listman.redhat.com/archives/fedora-directory-users/attachments/20050713/714d1f03/attachment.bin>

More information about the Fedora-directory-users mailing list