[Fedora-directory-users] Centos 4.1 - FDS Problems

Vik Lionheart neuromancer101 at hotmail.co.uk
Tue Jul 19 11:05:44 UTC 2005

Yes I have x11 installed, it is required for nomachine to run correctly, 
which has been installed correctly.

I tried running start-slapd as a non-root and, after fixing several 
permission errors I got the following message:

[user at node slapd-node]$ ./start-slapd
Server failed to start !!! Please check errors log for problems

Viewing the error log revealed the following:

[19/Jul/2005:11:56:12 +0100] - Warning - couldn't set the ownership for 
[19/Jul/2005:11:56:12 +0100] - Fedora-Directory/7.1 B2005.146.2010 starting 
[19/Jul/2005:11:56:12 +0100] createprlistensocket - PR_Bind() on All 
Interfaces port 389 failed: Netscape Portable Runtime error -5966 (Access 

This may be the reason why admin server kept randomly stopping. I've made 
sure that no other services are trying to run on port 389 but I still have 
this error.

>From: "Adam M. Dobrin" <adam at emplifyhr.com>
>Reply-To: "General discussion list for the Fedora Directory server 
>project." <fedora-directory-users at redhat.com>
>To: "General discussion list for the Fedora Directory server project." 
><fedora-directory-users at redhat.com>
>Subject: Re: [Fedora-directory-users] Centos 4.1 - FDS Problems
>Date: Mon, 18 Jul 2005 21:27:08 -0400
>it looks like you are having some issues here, with yourself.
>the admin server doesn't run on port 389, the LDAP server does.  It looks 
>like you aren't starting the LDAP server.
>your admin server is listening on port 40795.
>do you have X11 installed?
>Squall Lionheart wrote:
>>I'm currently using the Sun JDK, and it appears to have been configured 
>>correctly. I've trawled through the logs and there is nothing that even 
>>remotely looks like an error message. The admin server logs show that the 
>>adminserver started up sucessfully. Maybe I'm missing something??
>>>From: "Squall Lionheart" <neuromancer101 at hotmail.co.uk>
>>>Reply-To: "General discussion list for the Fedora Directory server 
>>>project." <fedora-directory-users at redhat.com>
>>>To: fedora-directory-users at redhat.com
>>>Subject: [Fedora-directory-users] Centos 4.1 - FDS Problems
>>>Date: Mon, 18 Jul 2005 11:50:48 +0100
>>>I can't seem to get fds to work. I have CentOS 4.1 installed and working 
>>>fine. FDS appears to have installed fine as well. When I run the admin 
>>>server as a non-root user no messages appear, and when I try and telnet 
>>>to port 389 it says connection is refused, meaning the admin server isn't 
>>>running at all. When I try startconsole I get the following as a non-root 
>>>Console: Can't connect to X11 window server using ':0.0' as the value of 
>>>the DISPLAY variable.
>>>When I run start-admin as root I get the following message:
>>>warning: daemon is running as super-user
>>>[LS ls1] http://node.internal-datacom.com, port 40795 ready to accept 
>>>But this doesn't stay. It appears that the admin server doesn't remain 
>>>running, maybe 5-10 seconds. Is there any way to fix this timeout problem 
>>>so that admin server remains running?
>>Be the first to hear what's new at MSN - sign up to our free newsletters! 
>>Fedora-directory-users mailing list
>>Fedora-directory-users at redhat.com
>Fedora-directory-users mailing list
>Fedora-directory-users at redhat.com

Want to block unwanted pop-ups? Download the free MSN Toolbar now!  

More information about the Fedora-directory-users mailing list