[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-directory-users] Re: Floating poing exception in Fedora DS installation

Ratnakar Sagare wrote:
Hi, Thanks for your reply. I checked on my system once again but no success yet.

I have ncurses-5.4-13 and libtermcap-2.0.8-39 installed on my system.

The error is coming right away and no dialog box for using existing config
is seen.
I tried with strace command also & here's the output of trace.out file which
I have created
execve("bin/slapd/admin/bin/ns-config", ["bin/slapd/admin/bin/ns-config",
"-f", "/tmp/a.inf", "-l", "/tmp/logA15446", "-m", "2"], [/* 24 vars */]) = 0
uname({sys="Linux", node="<my system's FQDN>", ...}) = 0
brk(0)                                  = 0x9841000
--- SIGFPE (Floating point exception) @ 0 (0) ---
+++ killed by SIGFPE +++

What it should do next is load /etc/ld.so.preload, then load all of the shared libraries and their dependencies. Do you have LD_LIBRARY_PATH set? If so, try without it. I would suggest looking at the output of ldconfig -p, but I'm not really sure what to look for.

Is it possible you are attempting to run a 64bit binary on a 32bit system? Or vice versa, though that should work. One thing about ns-config is that it is a C++ program, so perhaps there is some sort of C++ compat layer missing?

-----Original Message-----
Date: Mon, 03 Dec 2007 09:55:21 -0700
From: Rich Megginson <rmeggins redhat com>
Subject: Re: [Fedora-directory-users] Floating poing exception in
	Fedora DS	installation
To: "General discussion list for the Fedora Directory server project."
	<fedora-directory-users redhat com>
Message-ID: <475434F9 7050900 redhat com>
Content-Type: text/plain; charset="iso-8859-1"

Ratnakar Sagare wrote:
Hi all,

I am trying to install Fedora DS 1.0.4-1 on RHEL 4 system. I have installed the RPM for it. While running the setup it gives following error on my system.

I have installed jre 1.5.0 also.

./setup: line 520: 15606 Floating point exception./ns-config -f $inffile -l $logfile -m $installmode $doreconfig

ERROR Exiting . . .

Log file is /tmp/logi15532

Can you please help me out in this?

I just tried to reproduce this on a clean RHEL4 i386 system with the latest updates. It worked fine.

Do you get this error right away, or do you see the dialog box that asks you if you want to use an existing configuration DS?

Do you have the packages ncurses and libtermcap installed?

One thing you could try is to use strace to see what the program is doing. Line 520 doesn't look like the correct line, but just above that are the calls to ns-config. You could change those lines to something like "strace -o /tmp/trace.out ./ns-config ...."
Thanks in advance



Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]