[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-directory-users] Changes to passthru plugin from 1.0.2 to 1.0.4

Paul Engle wrote:
Hash: SHA1

We are currently running our production servers with FDS 1.0.2 on RHEL4 with the PAM passthru plugin enabled. I'm trying to set up a new 1.0.4 server so we can replicate the production databases over to it and then upgrade the older boxes in place.

I know that the PAM passthru plugin was included with the distro as of 1.0.3 (yay!), but it appears to have undergone some changes. When I try to turn it on, the error log gives:

passthru-plugin - no pass through servers found in configuration (at least one must be listed)
I think you're getting the PAM passthru plugin confused with the passthru plugin.
Reading the online Admin Guide about configuring the plugin seems to be referring to it being used for passing off auth from one ldap server to another, not for passing through to PAM.

I looked at the dse.ldif from the 1.0.2 server and tried just adding the pamConfig objectclass to the plugin object on the 1.0.4 server and adding in the appropriate attributes, but I still get the same error on startup.

Is there any other documentation other than the Admn Guide on setting up and using the plugin in a post-1.0.2 server? Or can anyone who's set this up offer any tips?


- -- Paul D. Engle | Rice University
Sr. Systems Adminstrator, RHCE      | Information Technology - MS119
713-348-4702                        | PO Box 1892
pengle rice edu                     | Houston, TX 77251-1892
Version: GnuPG v1.4.7 (MingW32)


Fedora-directory-users mailing list
Fedora-directory-users redhat com

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]