[389-users] Admin-console doesn't work after upgrade

Rich Megginson rmeggins at redhat.com
Wed Nov 4 15:34:40 UTC 2009

Jens Ådne Rydland wrote:
> On Wed, Nov 04, 2009 at 07:22:53AM -0700, Rich Megginson wrote:
>> Jens Ådne Rydland wrote:
>>> Right. And when I try to run setup-ds-admin.pl -u I'm asked about misc.
>>> information that I don't have readily available, but most of it is
>>> auto-filled in, and I guess it stored in some configuration file from
>>> the previous time the admin-server was set up?   
>> Right.  /etc/dirsrv/admin-serv/adm.conf mostly.  The only information  
>> you must provide is the admin password.  Everything else should be  
>> auto-filled in.
> Yes, everything is auto-filled in, except that when using just the
> auto-filled in information I get the error "Invalid credentials". So I
> suspected that I had somehow gotten the password wrong, and tried
> resetting it, but this didn't help.
>>> Seems like no matter what I enter it returns "Error:  No such object" or
>>> "Error: Invalid credentials". At least the last one I suppose means it
>>> managed to connect to the LDAP server, but got the wrong admin password
>>> or something? If it is the wrong password, how can I reset it?
>> Do you use the console?  What username and password do you use?  I  
>> suppose you could also use the directory manager DN and password for  
>> your configuration directory server (the server that holds the  
>> o=NetscapeRoot information).
> Using the console isn't possible as the console doesn't start, as stated
> in my first message in this thread. That is, I can't login with the
> console at least, it fails with 
> "netscape.ldap.LDAPException: error result (32); No such object". 
> I use the same username and password for the console that I've always
> used, and this is the same as what I enter when running
> setup-ds-admin.pl, which is rejected with "Error: Invalid credentials". 
Try this:
ldapsearch -x -h configdshostname -D "uid=admin, ou=Administrators, 
ou=TopologyManagement, o=NetscapeRoot" -w "consoleuserpassword" -s base 
-b "o=netscaperoot"

The -D binddn should be the same as what's in 

If this command gives you Invalid credentials, then you have most likely 
forgotten your console admin password, which is _not_ the same as the 
directory manager password, which is why following the directions below 
did not do anything.

If you need to reset your console admin password, do something like this:
ldapmodify -x -h configdshostname -D "cn=directory manager" -w 
dn: uid=admin, ou=Administrators, ou=TopologyManagement, o=NetscapeRoot
changetype: modify
replace: userPassword
userPassword: thenewpassword
> I have also tried resetting this password following the howto at
> http://directory.fedoraproject.org/wiki/Howto:ResetDirMgrPassword, but
> this didn't help either.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3258 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://listman.redhat.com/archives/fedora-directory-users/attachments/20091104/eb996755/attachment.bin>

More information about the Fedora-directory-users mailing list