[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpms/gallery2/FC-5 gallery2.spec,1.7,1.8



Author: jwb

Update of /cvs/pkgs/rpms/gallery2/FC-5
In directory cvs-int.fedora.redhat.com:/tmp/cvs-serv10150

Modified Files:
	gallery2.spec 
Log Message:
Fix nasty upgrade issue from 2.1 packages to 2.2 packages


Index: gallery2.spec
===================================================================
RCS file: /cvs/pkgs/rpms/gallery2/FC-5/gallery2.spec,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- gallery2.spec	7 May 2007 15:16:27 -0000	1.7
+++ gallery2.spec	10 May 2007 03:37:00 -0000	1.8
@@ -7,7 +7,7 @@
 Name: gallery2
 Version: 2.2
 Group: Applications/Publishing
-Release: 0.2.svn20070506%{?dist}
+Release: 0.3.svn20070506%{?dist}
 License: GPL
 # Source0: http://dl.sf.net/gallery/gallery-2.2-developer.tar.gz
 # Using SVN tarball for source to resolve provides issues sanely
@@ -697,11 +697,28 @@
 %clean
 rm -rf ${RPM_BUILD_ROOT}
 
+%post
+if [[ -f %{installprefix}/gallery2/config.php.rpmnew ]]
+then
+	echo Your old configuration file (config.php) has not been replaced.
+	echo Please move it to /etc/gallery2/config.php and rename the
+	echo config.php.rpmnew symlink to config.php.
+fi
+if [[ -f %{installprefix}/gallery2/config.php.rpmsave ]]
+then
+	echo Please ensure your /etc/gallery2/config.php file has the correct
+	echo contents, and the %{installprefix}/gallery2/config.php symlink is
+	echo pointed to it.
+fi
+echo If this is an upgrade from a previously installed version of Gallery2,
+echo please be sure to point a web browser at http://<hostname>/gallery2/upgrade/
+echo and follow the instructions there to complete the upgrade process.
+
 %files
 %defattr(-,root,root,-)
 %{installprefix}/gallery2/bootstrap.inc
 %{installprefix}/gallery2/embed.php
-%{installprefix}/gallery2/config.php
+%config(noreplace) %{installprefix}/gallery2/config.php
 %{installprefix}/gallery2/images/
 %{installprefix}/gallery2/index.php
 %{installprefix}/gallery2/init.inc
@@ -1030,6 +1047,10 @@
 %{installprefix}/gallery2/themes/tile/
 
 %changelog
+* Wed May  9 2007 John Berninger <johnw at berningeronline dot net> - 2.2-0.3.svn20070506
+- Mark the config.php symlink as a config file so that the config.php from 2.1
+  installs doesn't get overwritten.  Yes, I did a Bad Thing.
+
 * Mon May  7 2007 John Berninger <johnw at berningeronline dot net> - 2.2-0.2.svn20070506
 - Requires PHP 4.3.0, not 4.1.0
 - Add statement of support for DB2, MS SQL server


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]