[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpms/perl-libwhisker2/FC-6 libwhisker2-2.4-lw1bridge.patch, NONE, 1.1 libwhisker2-2.4-vendorlib.patch, NONE, 1.1 perl-libwhisker2.spec, NONE, 1.1 sources, 1.1, 1.2



Author: sindrepb

Update of /cvs/extras/rpms/perl-libwhisker2/FC-6
In directory cvs-int.fedora.redhat.com:/tmp/cvs-serv13970

Modified Files:
	sources 
Added Files:
	libwhisker2-2.4-lw1bridge.patch 
	libwhisker2-2.4-vendorlib.patch perl-libwhisker2.spec 
Log Message:
add files to branch

libwhisker2-2.4-lw1bridge.patch:

--- NEW FILE libwhisker2-2.4-lw1bridge.patch ---
--- libwhisker2-2.4/compat/LW.pm.orig	2007-05-08 16:00:52.000000000 +0200
+++ libwhisker2-2.4/compat/LW.pm	2007-05-08 16:01:24.000000000 +0200
@@ -1,3 +1,4 @@
+#!/usr7bin/perl
 #
 # This is a compatiblity 'bridge' which will translate the
 # libwhisker 2.x API into libwhisker 1.x format.  This should
--- libwhisker2-2.4/Makefile.orig	2007-05-08 16:02:49.000000000 +0200
+++ libwhisker2-2.4/Makefile	2007-05-08 16:02:21.000000000 +0200
@@ -11,6 +11,7 @@ build:
 install:
 	export DESTDIR
 	perl Makefile.pl install
+	perl Makefile.pl install_compat
 
 clean:
 	perl Makefile.pl clean

libwhisker2-2.4-vendorlib.patch:

--- NEW FILE libwhisker2-2.4-vendorlib.patch ---
--- libwhisker2-2.4/Makefile.pl.orig	2007-05-04 15:24:36.000000000 +0200
+++ libwhisker2-2.4/Makefile.pl	2007-05-04 15:25:07.000000000 +0200
@@ -228,7 +228,7 @@ sub command_install_library {
 	command_build() if(!-e $TARGET);
 	die("Can not install without Config.pm") if($MODULES{Config}==0);
 	$CWD=&cwd if($MODULES{Cwd}>0);
-	my $where=$DESTDIR . $Config{'installsitelib'};
+	my $where=$DESTDIR . $Config{'installvendorlib'};
 	if(!-e $where){
 	  print STDOUT "WARNING!\n\n",
 		"The local perl site directory does not exist:\n",
@@ -256,7 +256,7 @@ sub command_install_library {
 sub command_uninstall_library {
 	die("Can not uninstall without Config.pm") if($MODULES{Config}==0);
 	$CWD=&cwd if($MODULES{Cwd}>0);
-	my $where=$DESTDIR . $Config{'installsitelib'};
+	my $where=$DESTDIR . $Config{'installvendorlib'};
 	chdir($where);
 	if(-e $TARGET){
 		unlink $TARGET;
@@ -386,7 +386,7 @@ sub command_socket_diag {
 sub command_install_compat {
 	die("Can not install without Config.pm") if($MODULES{Config}==0);
 	$CWD=&cwd if($MODULES{Cwd}>0);
-	my $where=$DESTDIR . $Config{'installsitelib'};
+	my $where=$DESTDIR . $Config{'installvendorlib'};
 	if(!-e $where){
 	  print STDOUT "WARNING!\n\n",
 		"The local perl site directory does not exist:\n",


--- NEW FILE perl-libwhisker2.spec ---
Name:           perl-libwhisker2
Obsoletes:      perl-libwhisker <= 1.8
Provides:       perl-libwhisker = %{version}-%{release}
Version:        2.4
Release:        2%{?dist}
Summary:        Perl module geared specificly for HTTP testing

Group:          Development/Libraries
License:        GPL
URL:            http://www.wiretrip.net/rfp/lw.asp
Source0:        http://www.wiretrip.net/rfp/libwhisker/libwhisker2-%{version}.tar.gz
#install to vendorlib, not sitelib
Patch0:         libwhisker2-2.4-vendorlib.patch
#include libwhisker1 compatibility bridge
Patch1:         libwhisker2-2.4-lw1bridge.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

BuildArch:      noarch

BuildRequires:  perl
Requires:       perl(Net::SSLeay), openssl-perl  
Requires:       perl(MD5)
Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))

%description
Libwhisker is a Perl module geared specificly for HTTP testing.

%prep
%setup -qn libwhisker2-%{version}
%patch0 -p1
%patch1 -p1

%build
make %{?_smp_mflags}


%install
rm -rf $RPM_BUILD_ROOT
#create directories, not created by Makefile.pl
mkdir -p $RPM_BUILD_ROOT%{perl_vendorlib}
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3

make install DESTDIR=$RPM_BUILD_ROOT

#fix permissions
chmod 0644 $RPM_BUILD_ROOT/%{perl_vendorlib}/*

#%check
#cd t 
#perl ./test.pl

%clean
rm -rf $RPM_BUILD_ROOT


%files
%defattr(-,root,root,-)
%doc CHANGES LICENSE README
%{perl_vendorlib}/*
%{_mandir}/man?/*

%changelog
* Tue May 08 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 2.4-2
- Fix typo in Source0 url
- Update lw1bridge patch to not include License info
- Add explicit version to Provides and Obsoletes
- Added tests, commented out
- Cleaned up BuildRequires and Requires
* Fri May 04 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 2.4-1
- Initial build


Index: sources
===================================================================
RCS file: /cvs/extras/rpms/perl-libwhisker2/FC-6/sources,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- sources	11 May 2007 21:18:15 -0000	1.1
+++ sources	12 May 2007 00:36:29 -0000	1.2
@@ -0,0 +1 @@
+bdc618fa52bee38171c12e00bd99e18d  libwhisker2-2.4.tar.gz


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]