[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpms/dbmail/EL-5 .cvsignore, 1.3, 1.4 README.fedora, 1.1, 1.2 dbmail.spec, 1.6, 1.7 sources, 1.4, 1.5 dbmail-expunge.patch, 1.1, NONE dbmail-short-write.patch, 1.1, NONE kill-module-path.patch, 1.1, NONE



Author: bjohnson

Update of /cvs/pkgs/rpms/dbmail/EL-5
In directory cvs-int.fedora.redhat.com:/tmp/cvs-serv14323/EL-5

Modified Files:
	.cvsignore README.fedora dbmail.spec sources 
Removed Files:
	dbmail-expunge.patch dbmail-short-write.patch 
	kill-module-path.patch 
Log Message:
- update to svn 2.2.5rc3
- remove unneccessary patches
- make sqlite default driver for better out of the box experience




Index: .cvsignore
===================================================================
RCS file: /cvs/pkgs/rpms/dbmail/EL-5/.cvsignore,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- .cvsignore	13 Mar 2007 22:39:01 -0000	1.3
+++ .cvsignore	24 May 2007 07:17:30 -0000	1.4
@@ -1 +1 @@
-dbmail-2.2.4.tar.gz
+dbmail-2.2.5rc3.tar.gz


Index: README.fedora
===================================================================
RCS file: /cvs/pkgs/rpms/dbmail/EL-5/README.fedora,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- README.fedora	21 Feb 2007 06:35:36 -0000	1.1
+++ README.fedora	24 May 2007 07:17:30 -0000	1.2
@@ -1,19 +1,19 @@
 === README.fedora ===
 
 Currently,  DBMail supports MySQL, PostgreSQL and SQLite3 for mail storage.
-The drivers for these different databases are packaged separately.  In order
-to have a working system, you must install the driver for the database you wish
-to use.  If you do not select a driver at install time, a default driver will
-be installed.
+The drivers for these different databases are packaged separately, except
+SQLite, when it's available in the host os.  A default install will target
+SQLite support.  If you wish to use another database, you must install the
+appropriate driver.
 
 For example, to install dbmail and the dbmail-pgsql driver using yum:
 
 # yum install dbmail dbmail-pgsql
 
 The current choices for database driver are:
-  dbmail-mysql (default)
+  dbmail (built in SQLite datbase support by default)
+  dbmail-mysql
   dbmail-pgsql
-  dbmail-sqlite
 
 Additionally, you have a choice of authentication drivers as well:
   dbmail (built-in sql authentication by default)


Index: dbmail.spec
===================================================================
RCS file: /cvs/pkgs/rpms/dbmail/EL-5/dbmail.spec,v
retrieving revision 1.6
retrieving revision 1.7
diff -u -r1.6 -r1.7
--- dbmail.spec	23 Mar 2007 00:19:26 -0000	1.6
+++ dbmail.spec	24 May 2007 07:17:30 -0000	1.7
@@ -11,14 +11,14 @@
 %endif
 
 Name:           dbmail
-Version:        2.2.4
-Release:        4%{?dist}%{?repotag:.%{repotag}}
+Version:        2.2.5
+Release:        0.1.rc3%{?dist}%{?repotag:.%{repotag}}
 Summary:        The DBMail mail storage system
 
 Group:          System Environment/Daemons
 License:        GPL
 URL:            http://www.dbmail.org
-Source0:        http://www.dbmail.org/download/2.2/dbmail-%{version}.tar.gz
+Source0:        http://www.dbmail.org/download/2.2/dbmail-%{version}rc3.tar.gz
 Source1:        dbmail-imapd
 Source2:        dbmail-pop3d
 Source3:        dbmail-lmtpd
@@ -26,9 +26,7 @@
 Source5:        dbmail.cron
 Source6:        dbmail.logrotate
 Source7:        README.fedora
-Patch0:         kill-module-path.patch
-Patch1:         dbmail-expunge.patch
-Patch2:         dbmail-short-write.patch
+
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 BuildRequires:  fileutils, openssl >= 0.9.7a
@@ -42,9 +40,14 @@
 
 Requires:       glib2 >= 2.8, logrotate, initscripts, vixie-cron
 Requires:       initscripts
+Requires:       /usr/sbin/sendmail
 Requires(pre):  fedora-usermgmt
 Requires(postun):fedora-usermgmt
-Requires:       dbmail-database-driver = %{version}-%{release}
+%if ! 0%{?without_sqlite}
+Requires:       sqlite >= 3
+Obsoletes:      dbmail-sqlite < 2.2.5
+%endif
+
 
 %description
 Dbmail is the name of a group of programs that enable the possiblilty of
@@ -61,10 +64,7 @@
 installation and configuration in Fedora.
 
 %prep
-%setup -q
-%patch0 -p1 -b .kill-module-path
-%patch1 -p0 -b .expunge
-%patch2 -p0 -b .shortwrite
+%setup -q -n %{name}-%{version}rc3
 
 # we don't need README.solaris and we don't want it caught up in the %%doc
 # README* wildcard - but we do want our shiny new README.fedora file to be
@@ -72,6 +72,17 @@
 rm -f README.solaris
 install -p -m 644 %SOURCE7 .
 
+# make a couple of changes to the default dbmail.conf file:
+# 1. default driver/authdriver sqlite/sql (sqlite, if supported)
+# 2. effective uid/gid to dbmail/dbmail
+%if ! 0%{?without_sqlite}
+sed -i 's/\(^driver\W*=\)\(\W*$\)/\1 sqlite/' dbmail.conf
+%endif
+sed -i -e 's,\(^db\W*=\)\(.*$\),\1 %{_localstatedir}/lib/dbmail/dbmail.db,'   \
+       -e 's/\(^authdriver\W*=\)\(\W*$\)/\1 sql/'                             \
+       -e 's/\(^EFFECTIVE_USER\W*=\)\(.*$\)/\1 dbmail/'                       \
+       -e 's/\(^EFFECTIVE_GROUP\W*=\)\(.*$\)/\1 dbmail/' dbmail.conf
+
 %build
 %configure --disable-rpath \
            --disable-static \
@@ -93,6 +104,7 @@
 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/cron.daily
 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d
 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d
+mkdir -p $RPM_BUILD_ROOT/%{_localstatedir}/lib/dbmail
 install -p -m 755 %SOURCE1 $RPM_BUILD_ROOT/%{_initrddir}
 install -p -m 755 %SOURCE2 $RPM_BUILD_ROOT/%{_initrddir}
 install -p -m 755 %SOURCE3 $RPM_BUILD_ROOT/%{_initrddir}
@@ -162,6 +174,11 @@
 %{_sysconfdir}/cron.daily/dbmail
 %config(noreplace) %{_sysconfdir}/logrotate.d/dbmail
 %config(noreplace) %{_sysconfdir}/ld.so.conf.d/dbmail-*.conf
+%if ! 0%{?without_sqlite}
+%doc sql/sqlite/*
+%{_libdir}/dbmail/libsqlite*
+%dir %attr(0775,root,dbmail) /var/lib/dbmail
+%endif
 
 %package auth-ldap
 Summary:        The DBMail mail storage system
@@ -180,7 +197,6 @@
 Summary:        The DBMail mail storage system
 Group:          System Environment/Daemons
 Requires:       dbmail = %{version}-%{release}, mysql-server >= 4.1.3
-Provides:       dbmail-database-driver = %{version}-%{release}
 
 %description mysql
 This is the mysql libraries for dbmail.
@@ -194,7 +210,6 @@
 Summary:        The DBMail mail storage system
 Group:          System Environment/Daemons
 Requires:       dbmail = %{version}-%{release}, postgresql-server
-Provides:       dbmail-database-driver = %{version}-%{release}
 
 %description pgsql
 This is the postgresql libraries for dbmail.
@@ -204,23 +219,12 @@
 %doc sql/postgresql/*
 %{_libdir}/dbmail/libpgsql*
 
-%if ! 0%{?without_sqlite}
-%package sqlite
-Summary:        The DBMail mail storage system
-Group:          System Environment/Daemons
-Requires:       dbmail = %{version}-%{release}, sqlite
-Provides:       dbmail-database-driver = %{version}-%{release}
-
-%description sqlite
-This is the sqlite libraries for dbmail.
-
-%files sqlite
-%defattr(-,root,root,-)
-%doc sql/sqlite/*
-%{_libdir}/dbmail/libsqlite*
-%endif
-
 %changelog
+* Wed May 23 2007 Bernard Johnson <bjohnson symetrix com> 2.2.5-0.1.rc3
+- update to svn 2.2.5rc3
+- remove unneccessary patches
+- make sqlite default driver for better out of the box experience
+
 * Thu Mar 23 2007 Bernard Johnson <bjohnson symetrix com> 2.2.4-4
 - actually APPLY the short write patch
 


Index: sources
===================================================================
RCS file: /cvs/pkgs/rpms/dbmail/EL-5/sources,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- sources	13 Mar 2007 22:39:01 -0000	1.4
+++ sources	24 May 2007 07:17:30 -0000	1.5
@@ -1 +1 @@
-b7f56437df764e7046438f81f4b7df18  dbmail-2.2.4.tar.gz
+aa645b04fed7c0d851d9019f3e82bf2a  dbmail-2.2.5rc3.tar.gz


--- dbmail-expunge.patch DELETED ---


--- dbmail-short-write.patch DELETED ---


--- kill-module-path.patch DELETED ---


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]