[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: sqlite



On Mon, 14 Feb 2005 10:52:06 +0000, David Woodhouse wrote:

> On Mon, 2005-02-14 at 11:34 +0100, Michael Schwendt wrote:
> >No, the library sonames are not compatible. Hence the different package
> >name.
> 
> What is there that we need to remain compatible with?

Current dependencies in Extras are:

 * kannel
 * moodss
 * php-pecl-sqlite
 * python-sqlite

> Are there packages
> outside Fedora Extras which are using 'sqlite' by name and require
> version 2?

Can't answer that. It would be a package bug in a binary 3rd party
package to require 'sqlite' by name.

> When introducing new versions it's customary to rename the
> _old_ version and let the new version keep the real name, isn't it?

Sometimes only.

It makes sense to create sqlite3 packages and continue to let the v2
series use the 'sqlite' name as long as the v3 series is beta. Even after
the first non-beta 3.0.7 it can make sense to evaluate it further before
making it the new 'sqlite' main package.

> And
> if we do that, do we really need to keep 'sqlite2' around?

Well, currently only the sqlite v2 packages in Extras provide sqlite-tcl.
The Rawhide sqlite3 package doesn't.

> (My only interest here is that sqlite2 failed its own tests on PPC so I
> want it to die, btw: http://peach.infradead.org/extras/#sqlite :)

It also fails on x86_64.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]