[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: qcad and qt assistant



On Mon, 2005-02-14 at 20:31 +0100, Michael Schwendt wrote:
> On Mon, 14 Feb 2005 19:01:10 +0100, Gérard Milmeister wrote:
> 
> > I don't really see a problem of moving assitant over to qt. If qt-devel
> > is not installed, then assitant simply doesn't show the qt help, when
> > invoked.
> > I suppose that there are other apps around that use assistant as their
> > help viewer.
> > However I propose a simple solution for now: Copy the
> > binary /usr/lib/qt-3.3/bin/assistant to /usr/bin/qcad-assistant and
> > include it in the rpm for qcad.
> 
> I've sent two of the three attached patches upstream.
> 
> The first one opens a Qt warning dialog when Qt Assistant can't be
> launched or encounters other errors. The second one removes references to
> two missing images in the English manual.
> 
> The third is a diff against current spec file.

The problem here is that the warning dialog doesn't give the user a hint
that he has to install qt-devel.

I tried out my idea of a solution and included a copy of assistant
as /usr/libexec/qcad/assistant. However on installing the resulting rpm,
I get 

"unpacking of archive failed on
file /usr/libexec/qcad/assistant;4211154a: cpio: MD5 sum mismatch"

-- 
Gérard Milmeister
Langackerstrasse 49
CH-8057 Zürich


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]