[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Octave add-on packages



On Tue, 22 Feb 2005 09:36:13 -0600, Quentin Spencer wrote:

> My second question related to FFTW is why the Extras version is so old 
> (2.1.5), when version 3.0.1 has been out for nearly 2 years. Octave 
> supports only FFTW version 3. I recall freshrpms used to have a fftw3 
> package but it has been dropped. Is there less interest in version 3?

Brief look: ABI and API changes between 2.1.5 and the 3 series. Website
says:

    The API of FFTW 3.x is incompatible with that of FFTW 2.x, for reasons
    of performance and generality (see the FAQ the manual). We encourage
    you to upgrade, but we still maintain version 2.1.5 for legacy
    users. MPI parallel transforms are still only available in 2.1.5.

No immediate API users for the 3 series are included in Fedora Extras, but
dependencies which still need the 2.x API. Hence no particular interest in
creating a parallel-installable fftw3 package. Your package would be the
first to require the new API.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]