[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Request for Review: perl-Tk



On Wed, 2005-06-15 at 16:40 -0500, Steven Pritchard wrote:
> On Wed, Jun 15, 2005 at 10:04:55PM +0300, Ville Skyttä wrote:
> > perl(:MODULE_COMPAT_*) should be enough for the install time dependency,
> > no need for explicit versioned "Requires: perl >= 3:5.8.3" if you like
> > (as long as the versioned build dependency is there).
> 
> Except, like I said, that version is required for proper Unicode
> support.  (In other words, we don't want the package to build on old
> FC/RHL releases.)

Yes, and I was talking about _install_ time dependencies above.
Requires, not BuildRequires.  The versioned build dep is ok as is.

> > BuildRequires: tk-devel missing?
> 
> Tk.pm doesn't actually use the system tk libs.  It is a port of the C
> code to perl.  (As I understand it, anyway.)

Appears so, indeed.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]