$RPM_BUILD_ROOT vs. %buildroot (was: Re: potential candidates for contribution)
che666 at uni.de
Sun Mar 20 19:13:56 UTC 2005
Am Donnerstag, den 17.03.2005, 14:42 +0100 schrieb Michael Schwendt:
> On Thu, 17 Mar 2005 11:15:36 +0100, Rudolf Kastl wrote:
> > > > > Doesn't use $RPM_BUILD_ROOT/%buildroot consistently.
> > > >
> > > > is that really an issue?
> > >
> > > It's in the Packaging Guidelines, so yes it's an issue.
> > > http://fedoraproject.org/wiki/PackagingGuidelines#head-
> > > d0ada6130cf40be1244d34cc44fc38d34dd00db8
> > ya i just asked that question for the trivial reason that doesnt make a
> > difference at all besides some aestetic value ;).
> > id see more sense if one of the styles would be preferred else its a mix
> > up again repo wide.
> Fedora.us has tried to take that route before. Based on this message by
> Jeff Johnson,
> $RPM_BUILD_ROOT had been made an item in the fedora.us QA checklist. But
> this has be re-evaluated several months later when individual contributors
> and observers within the community, who prefer %buildroot for sake of
> readability, complained because the QA checklist created a blurred picture
> of what is mandatory and what is not. Since then, $RPM_BUILD_ROOT has been
> the preferred form in the "packaging hints" documentation, and using %buildroot
> is permitted. This item has been revisited for the Fedora Extras documentation.
> [As a side-note, using $RPM_BUILD_ROOT has been particularly dangerous in
> a few cases, where it appeared in scriptlets.]
this is a good argument so i might switch to a pure macro style. Seems
it made sense to bring that question up. I personally also think that a
pure macro style is alot easier on the eyes (no caps!) and also just
feels kinda cleaner to me.
Thanks for the suggestion.
> fedora-extras-list mailing list
> fedora-extras-list at redhat.com
More information about the fedora-extras-list