[Bug 167974] Review Request: hugs98 - Haskell Interpreter

bugzilla at redhat.com bugzilla at redhat.com
Tue Apr 18 19:18:24 UTC 2006


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Review Request: hugs98 - Haskell Interpreter


https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167974





------- Additional Comments From gemi at bluewin.ch  2006-04-18 15:18 EST -------
(In reply to comment #1)
> Apologies for "sitting" on this for too long.
Better late than never :-)

> 0) <http://cvs.haskell.org/Hugs/downloads/2005-03/>
> Upstream are now using YYYY-MM to label download dirs at least,
> so I wonder if it is better to use 2005.03 say for the version.
> (eg Gentoo is using 2005.3)
Ok

> 1) rpmlint complains:
> W: hugs98 invalid-license BSDish, see License file, GPL, LGPL
> I think just calling it BSD would be sufficient.
Ok

> 2) There seems to a small build problem on fc5:
> Skipping OpenAL package
There are quite some incompatibilities between openal 0.0.9
and previous versions.

> 3) Probably the description should be made more concise.
Is the first paragraph enough?

> 5) buildrequires need to be updated for modular X: I attach a diff below.
Ok
> 8) if demos/ (2.3MB) is to be included, it must be subpackaged into
> a separate subpackage (say hugs98-demos).
Ok, but I still install them into /usr/lib/hugs.
One could also subpackage the packages like opengl etc... I prefer
not to, but if you think it is better...


-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.




More information about the fedora-extras-list mailing list