[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Really strange permissions issue



On Sat, 2006-08-05 at 10:40 +0100, Paul wrote:
> Hi,
> 
> Bit of background.
> 
> As some know, I maintain quite a few packages and review even more. My
> old buildsys was a rescue job from a skip with a P2-600(ish) in. Last
> week, it finally died, but the drives were fine.
> 
> I replaced the drives into a P4-700 box, fired up and all was well. The
> system booted up and I could log in locally to all three users on the
> system (paul, build and su).
> 
> Normally, I don't log into the box, I ssh onto it. Tested that and it
> worked as well. Great.
> 
> Now I had to do an updated (the old box would die when updating). ssh to
> the box, su, yum -y update. yum complained saying it couldn't find a
> valid repo for extras or development.
> 
> Okay. Logged into the box directly (same user, build), yum -y update -
> same result. Logged out. Logged in as paul, started X, ran yumex and all
> was well.
> 
> Next time I updated. I directly logged in as build, tried running yum,
> same result. Logged out, logged in as paul, yum worked perfectly. At
> this point, I disabled selinux just incase.
> 
> Rebooted the buildsys.
> 
> Next test, ssh to the buildsys as paul. yum works fine.
> 
> Tried user build - same result - can't find repo.
> 
> This leads me to suspect a problem with user build, but I'm at a loss as
> to how to fix the problem. Any suggestions? I need to get user build
> working again as it's holding up a number of package reviews (as well as
> me submitting some more)

Look at the ownership and permissions of all of the yum config files and
their parent directories:

$ ls -ld / /etc /etc/yum*
$ ls -la /etc/yum.repos.d

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]