[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Python submodule naming

On 7/21/06, Luke Macken <lmacken redhat com> wrote:
I'm currently working on getting Paste{,Deploy,Script} though the review
process, and Patrice Dumas asks a good naming question in the bug[0]:

    I don't know if the name should be python-paste-deploy or
    python-pastedeploy. The guidelines don't cover the case of python
    submodules. If it is "This makes a package name format of python-$NAME"
    it seems to be python-pastedeploy, but if one follow "use the name of the
    module that you type to import it in a script" it should be
    python-paste-deploy. The second naming convention is also consistent
    with perl modules naming.

Anyone have any insight into this ?


[0]: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=198288#c2

FYI, Debian seems to go the second route without the second dash. I'm
inclined to go along.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]