[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [buildsys@fedoraproject.org: Prep Error (Job 14868): tetex-tex4ht-1_0_2006_08_26_2341-1_fc6 on fedora-development-extras]



On Mon, 2006-08-28 at 13:19 +0200, Patrice Dumas wrote:
> Hello,
> 
> I get a prep error for tetex-tex4ht. It may come from:
> 
> %{!?_texmf: %define _texmf %(eval "echo `kpsewhich -expand-var '$TEXMFMAIN'`")}
> 
> but there is
> BuildRequires:  /usr/bin/kpsewhich
> 
> (and even 
> BuildRequires:  tetex-fonts
> and tetex-fonts still contains kpsewhich).
> 
> Anybody knows what is wrong?

I suspect that this error is happening when mock is trying to build the
SRPM. It does this by parsing the spec file after only installing the
packages from the minimal buildroot, which doesn't include the packages
you're added as BuildRequires. So the spec file needs to be parse-able
when kpsewhich isn't present.

Perhaps something like:

%{!?_texmf: %define _texmf %(eval "[ -x /usr/bin/kpsewhich ] && echo
`kpsewhich -expand-var '$TEXMFMAIN'` || echo %{_datadir}/texmf")}

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]