[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 175433] Review Request: tor - Anonymizing overlay network for TCP (The onion router)



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Review Request: tor - Anonymizing overlay network for TCP (The onion router)


https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=175433





------- Additional Comments From kevin tummy com  2006-01-05 21:53 EST -------
Sorry for the delay in continuing the review. :( 

>I really want to avoid the bloaty initscripts/lsb; they add lot of
>stuff which is unneeded and there is no chance to modularize this
>package.
>
>'initscripts' itself is not tight very much into the system; e.g. my
>tor-vserver (with 'tor-minit') has it only because of
>
>| $ LANG=C vrpm cheese -- -e --test initscripts 
>| error: Failed dependencies:
>|         initscripts >= 3.94 is needed by (installed) pam-0.79-9.6.i386
>|         initscripts >= 8.11-1 is needed by (installed) >hotplug-2004_09_23-7.i386
>
>'hotplug' is brought in by 'initscripts' and I just submitted a bug
>#176508 to remove the dependency in 'pam'.

Well, thats your system... on my pretty much default fedora devel test box I get: 

[root testbox ~]# rpm -e --test initscripts
error: Failed dependencies:
        initscripts >= 5.83 is needed by (installed) glibc-kernheaders-3.0-2.i386
        initscripts >= 7.22-1 is needed by (installed) rhgb-0.16.2-12.i386
        initscripts >= 8.04-1 is needed by (installed) hal-0.5.5.1-2.1.i386
        initscripts >= 5.86-1 is needed by (installed) kbd-1.12-12.1.i386
        initscripts >= 8.11-1 is needed by (installed) hotplug-2004_09_23-10.1.i386
        initscripts >= 7.31.11.EL-1 is needed by (installed)
ipsec-tools-0.6.3-1.1.i386
        initscripts is needed by (installed) bluez-utils-2.22-2.1.i386
        initscripts >= 5.54 is needed by (installed) portmap-4.0-65.1.i386
        initscripts is needed by (installed) xorg-x11-xfs-1.0.0-1.i386
        initscripts is needed by (installed) xinetd-2.3.13-6.1.i386
        initscripts >= 0:5.54-1 is needed by (installed) samba-3.0.20b-2.1.i386
        initscripts >= 0:5.99 is needed by (installed)
system-config-network-tui-1.3.30-2.1.noarch
        initscripts >= 8.11.1-1 is needed by (installed)
kernel-2.6.14-1.1771_FC5.i686
        initscripts >= 6.38 is needed by (installed) quota-3.13-1.1.i386
        initscripts >= 0:5.99 is needed by (installed)
system-config-packages-1.2.25-1.1.noarch
        initscripts >= 7.73 is needed by (installed) dhcpv6_client-0.10-15.2.i386
        initscripts >= 8.11.1-1 is needed by (installed)
kernel-2.6.14-1.1773_FC5.i686
        initscripts >= 8.11.1-1 is needed by (installed)
kernel-2.6.14-1.1776_FC5.i686
        initscripts >= 5.20 is needed by (installed) openssh-4.2p1-10.i386
        initscripts is needed by (installed) system-config-printer-0.6.146-1.i386
        initscripts >= 6.75 is needed by (installed) dhclient-3.0.3-18.i386
        initscripts >= 8.11.1-1 is needed by (installed)
kernel-2.6.14-1.1777_FC5.i686
        initscripts >= 8.11.1-1 is needed by (installed)
kernel-2.6.14-1.1783_FC5.i686
        initscripts >= 8.11.1-1 is needed by (installed)
kernel-2.6.14-1.1800_FC5.i686
        initscripts >= 8.11.1-1 is needed by (installed)
kernel-2.6.14-1.1805_FC5.i686
        initscripts >= 8.11.1-1 is needed by (installed)
kernel-2.6.14-1.1806_FC5.i686
        initscripts >= 8.11.1-1 is needed by (installed)
kernel-2.6.14-1.1807_FC5.i686
        initscripts >= 8.11.1-1 is needed by (installed)
kernel-2.6.14-1.1808_FC5.i686
        initscripts is needed by (installed) foomatic-3.0.2-30.i386
        initscripts >= 8.11.1-1 is needed by (installed)
kernel-2.6.15-1.1819_FC5.i686
        /bin/usleep is needed by (installed) bind-9.3.2-1.i386
        /sbin/service is needed by (installed) athcool-0.3.11-3.fc5.i386
        /sbin/service is needed by (installed) distcache-1.4.5-12.1.i386
        /sbin/service is needed by (installed) bluez-utils-2.22-2.1.i386
        /sbin/service is needed by (installed) acpid-1.0.4-1.1.i386
        /sbin/service is needed by (installed) vixie-cron-4.1-42.FC5.i386
        /sbin/service is needed by (installed) smartmontools-5.33-4.i386
        /sbin/service is needed by (installed) xorg-x11-xfs-1.0.0-1.i386
        /sbin/service is needed by (installed) xinetd-2.3.13-6.1.i386
        /sbin/service is needed by (installed) spamassassin-3.1.0-3.fc5.1.i386
        /sbin/service is needed by (installed) rng-utils-2.0-1.9.1.i386
        /sbin/service is needed by (installed) irqbalance-1.12-1.21.1.i386
        /sbin/service is needed by (installed) cpuspeed-1.2.1-1.28.i386
        /sbin/service is needed by (installed) microcode_ctl-1.12-1.27.1.i386
        /sbin/service is needed by (installed) cups-1.1.23-27.i386
        /sbin/service is needed by (installed) cyrus-sasl-2.1.21-9.i386
        /sbin/service is needed by (installed) yum-2.4.1-1.fc4.noarch
        /sbin/service is needed by (installed) munin-node-1.2.4-5.fc5.noarch

If you have a need to remove that, wouldn't you just keep a local version of the
package that doesn't depend on initscripts/lsb? No need to do that for every
fedora-extras using box, is there?

>Does not work because 'initng' and 'minit' do not need/provide a
>pidfile. I find it also a little bit ... mmmh ... risky to send
>signals to a foreign process just because its pid appears in some
>file.

Yeah, I got that from the httpd package, but I agree it's kinda odd. 
The reload in logrotate sounds like a fine way to go. 

The 0.1.0.16-0 version builds fine under mock and works great on my test machine. 

Anyone else want to give thoughts on the tor-lsb subpackage?
Thats the only issue left I see on this package.


-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]