[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Bug 177619] Review Request: python-nltk-lite: Python libraries and programs for natural language processing



Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Review Request: python-nltk-lite: Python libraries and programs for natural language processing


https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=177619





------- Additional Comments From roozbeh farsiweb info  2006-01-15 12:05 EST -------
Not a full review yet, but random suggestions for the beginning:
- The license file looks to be a stripped version of GPL, which is illegal to
redistribute, as GPL only allows verbatim copies. I suggest contacting upstream.
- Source0 should use %{version} instead of a hardcoded 0.6.1
- Don't use 'cp -ap' as '-a' also implies '-p': use either '-rp' or '-a' based
on the situation
- Remove the requirement on python-devel. it's not required to build the package.
- I get a warning during build:
/usr/lib/python2.4/site-packages/nltk_lite/parse/chunk.py:1247: SyntaxWarning:
import * only allowed at module level
- You should perhaps use 'install -d' instead of 'mkdir -p'


-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]