[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Broken packages



Steven Pritchard wrote:
On Fri, Jun 02, 2006 at 03:49:29PM +0100, PFJ wrote:
I've noticed on the nightly broken packages lists that a number keep
cropping up for the rawhide builds, amongst them is qparted.
Since you bring up qtparted, it fails to build on rawhide right now.
I haven't had time to figure out why yet.
Is it not building at all or just in mock?

It appears to not build at all, but, again, I haven't really had the
time to look into it.

It's failing to build because of a change in parted-devel between FC5 and rawhide.

On FC5, the file /usr/include/parted/unit.h has:

#define PED_SECTOR_SIZE   512LL

On rawhide, the equivalent is:

#define PED_SECTOR_SIZE_DEFAULT	512LL

qtparted uses the PED_SECTOR_SIZE symbol, which on rawhide is undefined, so it fails. The attached patch gets it building again.

Paul.
--- qtparted-0.4.5/src/qp_libparted.h	2006-06-02 17:49:42.000000000 +0100
+++ qtparted-0.4.5/src/qp_libparted.h	2006-06-02 17:51:18.000000000 +0100
@@ -35,6 +35,10 @@
 #include "qtparted.h"
 #include "qp_devlist.h"
 
+#ifndef PED_SECTOR_SIZE
+#define PED_SECTOR_SIZE PED_SECTOR_SIZE_DEFAULT
+#endif
+
 class QP_PartWidget;
 class QP_ListViewItem;
 class QP_LibParted;

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]