[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: require foo or bar?



On Sat, 2006-06-03 at 06:43 -0700, Michael A. Peters wrote:
> On Sat, 2006-06-03 at 15:29 +0200, Christoph Wickert wrote:
> > 
> > On the other hand: What about ppc users? There's no lm_sensors for ppc,
> > so these people are not able to use the package if I make it depend on
> > lm_sensors.
> > 
> > Another question: This is a noarch python package. 
> > > BuildArch: noarch
> > > ExcludeArch: ppc
> > looks a bit silly to me.
> 
> Don't require lm_sensors
> 
> Users who need that functionality will have to know to install it - but
> there's no clean way to do it otherwise. Not that I am aware of.

Depending on the target distro versions and how well depsolvers for
those cope with it, Requires(hint) could be worth considering for both
dependencies.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]