[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Reverting package to a previous



On Tue, 2006-06-06 at 13:55 -0500, Jason L Tibbitts III wrote:
> >>>>> "GM" == Gérard Milmeister <gemi bluewin ch> writes:
> 
> GM> I updated the erlang package to the latest version
> GM> (R10B->R11B). However it the packages erlang-esdl, and thus, wings
> GM> do not work correctly.
> 
> Ouch.
You describe exactly my feelings :-(

> GM> How can I downgrade to the previous version?
> 
> You have to release a new package that has a higher
> epoch:version:release triple than the old package.  So you can either
> increase the epoch, or lie about the version.
> 
> GM> If so, what is the procedure for CVS?
> 
> Hmmm.  It doesn't look like the epoch is included in the CVS tags.  I
> wonder how well it will work in practice.
> 
> Anyway, to include an epoch, just add "Epoch: 1" to your spec.  But
> keep in mind that you'll have to keep it around forever.
Yes, that's the downside.

I could wait for the problem to be resolved in esdl and wings. There
seems to be an awareness of this, however nothing happened yet.
-- 
Gérard Milmeister
Langackerstrasse 49
CH-8057 Zürich


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]