[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Buildsys glitch?



On 10/06/06, Jonathan Underwood <jonathan underwood gmail com> wrote:
Hi,

I just pushed builds for an updated emacs-auctex package for FC-4,
FC-5 and devel. FC-4 and devel succeeded (specs are the same), but
FC-5 fails during configure with this:

checking for emacs... /usr/bin/emacs
checking if /usr/bin/emacs is XEmacs... cat: ./conftest-478: No such
file or directory
configure: error: Unable to run /usr/bin/emacs!  Aborting!
error: Bad exit status from /var/tmp/rpm-tmp.55095 (%build)

which seems like a build system issue - emacs is in the BuildRequires
and is clearly installed? The same package builds for me locally on
FC-5, but I haven't had the time to do a mock build yet as the machine
I usually use for that is offline due to a power outage at work.


The relevant part of the configure script is:

echo "$as_me:$LINENO: checking if ${EMACS} is XEmacs" >&5
echo $ECHO_N "checking if ${EMACS} is XEmacs... $ECHO_C" >&6

 elisp="(if (featurep (quote xemacs)) \"yes\" \"no\")"
 OUTPUT=./conftest-$$
 echo "${EMACS}" -batch -no-site-file -eval "(let* ((x ${elisp}))
(write-region (if (stringp x) x (prin1-to-string x)) nil
\"${OUTPUT}\"))"  >& 5 2>&1
 "${EMACS}" -batch -no-site-file -eval "(let* ((x ${elisp})) (write-region (if
(stringp x) x (prin1-to-string x)) nil \"${OUTPUT}\"))"  >& 5 2>&1
 XEMACS="`cat ${OUTPUT}`"
 echo "=> ${XEMACS}" >& 5 2>&1
 rm -f ${OUTPUT}

if test "${XEMACS}" = "yes"; then
 EMACS_FLAVOR=xemacs
 EMACS_NAME="XEmacs"
elif test "${XEMACS}" = "no"; then
 EMACS_FLAVOR=emacs
 EMACS_NAME="Emacs"
else
 { { echo "$as_me:$LINENO: error: Unable to run ${EMACS}!  Aborting!" >&5
echo "$as_me: error: Unable to run ${EMACS}!  Aborting!" >&2;}


which is failing at XEMACS="`cat ${OUTPUT}`"  for reasons I can't fathom.

Jonathan.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]