[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: desktop-file-install problem



On Sun, 11 Jun 2006 22:57:45 +0100, Paul wrote:

> Hi,
> 
> I seem to have hit a problem with the desktop file used in CastPodder
> (currently waiting review for FE) - there is a problem with the spec
> file which I'm working on...
> 
> I have included a desktop-file-install section in the install which
> looks like this
> 
> %install

rm -rf %{buildroot}

is missing here at beginning of %install section.

> mkdir -p %{buildroot}/%{_bindir}
> mkdir -p %{buildroot}/%{_datadir}/%{name}
> mkdir -p %{buildroot}/opt/%{name}
> cp -f -R * %{buildroot}/opt/%{name}
> cp -f %{buildroot}/opt/%{name}/%{name}.sh
> %{buildroot}/%{_bindir}/%{name}
> chmod -R 755 %{buildroot}/opt/%{name}/*.py
> desktop-file-install  --vendor fedora \
>         --dir %{buildroot}%{_datadir}/applications \
>         --add-category X-Fedora \
>         --delete-original \
>         %{buildroot}%{_datadir}/applications/CastPodder.desktop
> install -m644 %{SOURCE1} -D %{buildroot}/%{_miconsdir}/%{name}.png
> install -m644 %{SOURCE2} -D %{buildroot}/%{_iconsdir}/%{name}.png
> install -m644 %{SOURCE3} -D %{buildroot}/%{_liconsdir}/%{name}.png
> 
> When I run rpmbuild on the specfile though, the build works until it
> gets to the desktop-file-install which gives
> 
> + desktop-file-install --vendor fedora
> --dir /var/tmp/CastPodder-5.0-3-root-paul/usr/share/applications
> --add-category X-Fedora
> --delete-original /var/tmp/CastPodder-5.0-3-root-paul/usr/share/applications/CastPodder.desktop
> Error on file
> "/var/tmp/CastPodder-5.0-3-root-paul/usr/share/applications/CastPodder.desktop": Failed to open file '/var/tmp/CastPodder-5.0-3-root-paul/usr/share/applications/CastPodder.desktop' : No such file or directory
> 
> As I understand it, shouldn't the desktop-file-install copy from {BUILD}
> to %{buildroot}%{_datadir}/applications/ the .desktop file or is there
> something I'm missing (which is possible)?
> 
> I have tried the spec file with and without the --delete-original and
> get the same results.

Eh? Does the file exist in the buildroot? You sound as if it does
not exist.

If you list %{buildroot}/%{_datadir}/applications, does the original
CastPodder.desktop file exist?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]