[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: build system issue



Ian Chapman wrote:
Hi,
The problem is, that mock is installing an older version of lua (5.1-5) which provides lua-devel in the main package, even though lua-devel was provided as a seperate RPM. This problem was fixed in version lua 5.1-6 which has been available for about a week.

Question is, what's the best way to deal with this?

The simplest workaround is to add the BuildRequires: lua-devel >= 5.1-6.

Another way is to ask for the maintainer of lua to request buildsys
to remove the version 5.1-5 of lua by using
http://fedoraproject.org/wiki/Extras/FC5Status
(see https://www.redhat.com/archives/fedora-extras-list/2006-June/msg00570.html ).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]