[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: build system issue



Michael Schwendt wrote:
On Wed, 14 Jun 2006 18:16:36 +0100, Ian Chapman wrote:


Hi,

I'm currently trying to build the package cegui, which succeeds for devel, but fails on fc4 and fc5. cegui depends on tolua++-devel, which in turn depends on lua-devel. The problem is, that mock is installing an older version of lua (5.1-5) which provides lua-devel in the main package, even though lua-devel was provided as a seperate RPM. This problem was fixed in version lua 5.1-6 which has been available for about a week.

Buildlogs:
http://buildsys.fedoraproject.org/logs/fedora-4-extras/10942-cegui-0.4.1-8.fc4/x86_64/
http://buildsys.fedoraproject.org/logs/fedora-5-extras/10943-cegui-0.4.1-8.fc5/i386/

Question is, what's the best way to deal with this?


[...]
--> Running transaction check
--> Processing Dependency: libtolua++-5.1.so for package: tolua++-devel
--> Processing Dependency: lua-devel >= 5.1 for package: tolua++-devel
--> Processing Dependency: tolua++ = 1.0.92-3.fc5 for package: tolua++-devel
--> Processing Dependency: liblua-5.1.so for package: tolua++-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.

It's Yum's very own way of picking a package which satisfies these
requirements "lua-devel >= 5.1 and liblua-5.1.so",

  $ repoquery --whatprovides liblua-5.1.so
  lua-0:5.1-6.fc5.i386
  lua-0:5.1-5.fc5.i386          (!)

  $ repoquery --whatprovides lua-devel
  lua-devel-0:5.1-6.fc5.i386
  lua-0:5.1-5.fc5.i386          (!)
  lua-devel-0:5.1-5.fc5.i386

instead of picking the really latest packages, which you would get
after another "yum update".

There are other (related) cases like this, e.g. failure to notice
obsolete sub-packages: http://bugzilla.redhat.com/190116

Most convenient work-around is to get rid of the old lua in the
repository. You would submit such a request via the Wiki. See
the Repository Status pages in the middle of:
http://fedoraproject.org/wiki/Extras


The request to have the older offending package removed has been requested.

Michael


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]