[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Mock and old distributions



Jesse Keating wrote:
On Mon, 2006-06-26 at 22:31 +0100, Paul Howarth wrote:
Seeing that the need for elfutils in the buildroot for FC4 was
discussed
in the latest FESCO meeting, I thought I'd report the results of my
efforts to build packages for various old distributions using the
current version of mock on FC5:


Thats awesome Paul!  Any chance I could get you to add this to the wiki
somewhere so that it won't be lost?  I'm sure we'll need this info at
some point.

I'll update the Legacy/Mock page on the wiki. However, first I'd like to know what, if anything, will get fixed upstream or in the infrastructure.

For instance, the mock package in Extras is currently shipping with config files for Red Hat Linux 7.3 and 9, plus Fedora Core 1-devel. The best place to fix the issue of needing "su" rather than "runuser" for FC2 and earlier would be in these config files (i.e. an upstream fix).

Similarly, the differing requirements for packages needed in the buildroots would best be addressed by having the existing infrastructure at http://buildsys.fedoraproject.org/buildgroups/ updated to include buildsys-build packages for all of the mock-supported distributions with the correct dependencies for each.

I can raise bugs for these issues if that's preferred.

That would then just leave the issues that end users need to address on their own systems, which are best described on the wiki (though adding a reference to the wiki pages might be a useful addition to the mock README).

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]