[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: soname change policy proposal



Hans de Goede <j w r degoede    > writes:
> 1) When a package update would cause an soname change then a compat
>   package with the old libraries must be provided for all release repos,
>   that is for all repos except devel.

IMHO this is ridiculous. Even Core doesn't follow such a strict policy. This is 
going to hinder critical security upgrades for packages such as SeaMonkey, and 
also leave rapidly-changing libraries (which are the ones needing version 
upgrades the most!) stale at old versions (and you can quickly end up with 
dozens of compat packages for the same library if it is _really_ rapidly 
changing). I think the current policy of simply getting packages rebuilt if a 
soname changes (which is also what is done when Core upgrades a soname) works 
well.

        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]