[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/lesstif/devel lesstif.spec,1.4,1.5



On Mon, 1 Jan 2007 09:47:25 -0500, Patrice Dumas (pertusus) wrote:

> Author: pertusus
> 
> Update of /cvs/extras/rpms/lesstif/devel

> Log Message:
> * Mon Jan  1 2007 Patrice Dumas <pertusus free fr> 0.95.0-11
> - add debian patcheset
> - Conflict with openmotif versions provided in older fedora core releases
>   (should fix #221083)

> -# This is not needed and may conflit with openmotig packaging
> -# outside of fedora
> -#Conflicts: openmotif-devel
> +# Conflicts with openmotif found in older fedora releases
> +Conflicts: openmotif-devel <=  2.3.0-0.2.1
> +

>  %changelog
> +* Mon Jan  1 2007 Patrice Dumas <pertusus free fr> 0.95.0-11
> +- add debian patcheset
> +- Conflict with openmotif versions provided in older fedora core releases
> +  (should fix #221083)
> +
>  * Thu Aug 31 2006 Patrice Dumas <pertusus free fr> 0.95.0-10
>  - remove Conflicts: openmotif-devel, it isn't needed for fedora and
> -  may hurt external packaging of openmotif. Fix #208380.
> +  may hurt external packaging of openmotif. Fix #208380

Now you're back at Aug 31 2006, bug 208380. Old releases of Fedora Core
come with openmotif. Installs of FC <= 5 have openmotif installed.
Lesstif is an API-compatible replacement for Motif. Packages are rebuilt
against lesstif. An explicit conflict will break an upgrade, since lesstif
cannot be installed. You really want proper "Obsoletes" tags [and no
"Provides"].


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]