[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/lesstif/devel lesstif.spec,1.4,1.5



On Mon, Jan 01, 2007 at 04:14:12PM +0100, Michael Schwendt wrote:
> > -#Conflicts: openmotif-devel
> > +# Conflicts with openmotif found in older fedora releases
> > +Conflicts: openmotif-devel <=  2.3.0-0.2.1
> 
> Now you're back at Aug 31 2006, bug 208380. Old releases of Fedora Core

No, because the conflict is now versionned, with the version corresponding
to the latest openmotif shipped in fedora. So now it is possible to 
package newer openmotif-devel versions non conflicting with lesstif-devel,
and there is abetter erroring for those who try to upgrade from older 
FC releases and have openmotif-devel installed. It is still bad, though, 
see below.

> come with openmotif. Installs of FC <= 5 have openmotif installed.
> Lesstif is an API-compatible replacement for Motif. Packages are rebuilt
> against lesstif. An explicit conflict will break an upgrade, since lesstif
> cannot be installed. You really want proper "Obsoletes" tags [and no
> "Provides"].

It will only break if lesstif-devel is installed. lesstif and openmotif 
packages do not conflict. I would like to avoid having lesstif-devel obsolete
openmotif-devel, since it is not true, and I don't want to play bad with
third party repo packaging newer openmotif versions. Maybe a versioned 
obsolete would be less problematic, but even that is dubious.

If somebody has openmotif-devel installed and also a package depending on 
lesstif-devel there's trouble for upgrade path. Hrm. Maybe a versioned 
Obsolete, like

Obsoletes: openmotif-devel <=  2.3.0-0.2.1

I really dislikes that, but there may not be another solution.

--
Pat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]