[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/lesstif/devel lesstif.spec,1.4,1.5



On Mon, 1 Jan 2007 18:27:08 +0100, Patrice Dumas wrote:

> On Mon, Jan 01, 2007 at 05:21:23PM +0100, Michael Schwendt wrote:
> > 
> > Incomplete. Ought to be:
> > 
> >   Obsoletes: openmotif <= 2.3.0-0.2.1
> 
> This is not strictly required, but not doing that could lead to trouble 
> later when the lesstif sonames are bumped in the future, and considering 
> that the -devel package will obsolete older openmotif this is not that
> problematic, and it will get rid of old fedora openmotif.

lesstif-devel:
  Obsoletes: openmotif-devel <= ...
lesstif:
  Obsoletes: openmotif <= ...

Only a properly packaged OpenMotif with a higher version number can bring back
"openmotif" and "openmotif-devel" for FC6 and later.

> >   Obsoletes: openmotif-devel <=  2.3.0-0.2.1
> > 
> > I like it, FWIW. ;-)
> 
> Once agin I dislike it because there are certainly scenarios for which
> it will really bother third party repo openmotif packaging.

It has been a Core package. 3rd parties need to choose a version number
that is higher than in Core, anyway, and hence would not be affected by
the Obsoletes anyway.

However, they will see the implicit conflicts unless they re-package
their OpenMotif in a non-conflicting way.

> Indeed that could be a good idea to have fesco people have a look at that.
> I'll implement the versioned obsoletes, but maybe it could deserve a thorough
> look at it.

Again, to emphasise my concerns: first link in bug #221083, a conflict is
bad.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]