[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/lesstif/devel lesstif.spec,1.4,1.5



Patrice Dumas wrote:

> On Mon, Jan 01, 2007 at 05:21:23PM +0100, Michael Schwendt wrote:
>> 
>> Incomplete. Ought to be:
>> 
>>   Obsoletes: openmotif <= 2.3.0-0.2.1
> 
> This is not strictly required, but not doing that could lead to trouble
> later when the lesstif sonames are bumped in the future, and considering
> that the -devel package will obsolete older openmotif this is not that
> problematic, and it will get rid of old fedora openmotif.
> 
>>   Obsoletes: openmotif-devel <=  2.3.0-0.2.1
>> 
>> I like it, FWIW. ;-)
> 
> Once agin I dislike it because there are certainly scenarios for which
> it will really bother third party repo openmotif packaging.

As far as we (Fedora) are concerned, lesstif-devel *does* effectively
Obsoletes: openmotif-devel

Even though your Conflicts is correct (ie, not wrong), Michael's suggestion
of using (versinoed) Obsoletes in this case is, imo, a better option.

-- Rex


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]