[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/lesstif/devel lesstif.spec,1.4,1.5



Patrice Dumas wrote:

> On Mon, Jan 01, 2007 at 10:08:22PM -0600, Rex Dieter wrote:
>> 
>> Even though your Conflicts is correct (ie, not wrong), Michael's
>> suggestion of using (versinoed) Obsoletes in this case is, imo, a better
>> option.
> 
> That's what I used. If Ralf doesn't raise any concern I'll keep the
> versionned obsoletes.

I just checked cvs, and the latest devel/lesstif.spec includes

# obsolete older openmotif. May hurt third party repos
Obsoletes: openmotif <=  2.3.0-0.2.1

which is way not right.  See my comments in the package review:
http://bugzilla.redhat.com/203274#c11 (item 1)

It's seems to have been added due to
http://bugzilla.redhat.com/221083
But that only ever referred to -devel conflicts.

For now, it is my strong opinion that *at most*, only openmotif-devel should
be Obsoleted, but not the runtime.  

It *may* be ok, to 
Obsoletes: openmotif21
since it genuinely conflicts (same soname), see
http://bugzilla.redhat.com/215560

-- Rex


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]