[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/lesstif/devel lesstif.spec,1.4,1.5



On Thu, Jan 04, 2007 at 05:43:40PM +0100, Michael Schwendt wrote:
> > Maybe a Conflict would be better, with an explicit dependency on lesstif for 
> > packages built against lesstif-devel. Otherwise one may end with lesstif 
> > installed and packages built against openmotif21, although they are
> > binary incompatible. What's your advice?
> 
> 1.) You cannot link against openmotif21 since it doesn't provide the
> necessary .so symlinks. It doesn't store its libraries in %_libdir either,
> so the linker search path would be different, too.

There may be packages linked against openmotif21 existing, requiring 
libXm.so.2 which is also provided by lesstif.

> 2.) Are they really *binary* compatible?

No, they are binary incompatible.
 
> 3.) Conflicts during installation/upgrade is among the typical "WTF?"
> scenarios. Avoid them like the plague.

Indeed, but with an obsolete, it is possible to end up with packages
built against openmotif21 (old packages lying around), using the
lesstif provided library.

--
Pat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]