[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Geany: could not load libvte.so



Michael Schwendt wrote:
On Fri, 19 Jan 2007 08:16:17 -0800, Christopher Stone wrote:

On 1/19/07, Mark Knoop wrote:
I saw this editor newly in Extras, so gave it a try.

$ geany
** INFO: debug mode built in (can't be disabled)
** INFO: GTK+ 2.10.4, GLib 2.12.3
** INFO: Could not load libvte.so, terminal support disabled

It works fine if I symlink /usr/lib/libvte.so.9 to /usr/lib/libvte.so.
I would BZ this, but the geany component is not yet in Bugzilla.
This looks like a vte bug to me.  I did not get this error when I
reviewed the package.  Therefore the vte package appears to be fine on
my system.  Are you running FC-6?

Bug is reproducible on a FC-6. Just make sure you don't have "vte-devel"
installed.

That geany dlopen()'s libvte.so at run-time, is a bug in geany. It
ought to open the specific libvte.so.9 instead, since it was built with a specific vte-devel. See "src/vte.c".

Hmm, I have vte-devel as a BuildRequires, should I make it a Requires as well to fix this problem or should I actually patch geany to fix this issue?

Josef


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]