[Fedora-haskell-list] Packaging guidelines and macros update
petersen at redhat.com
Mon Dec 1 06:12:32 UTC 2008
> I would like to rename %ghc_postinst_script to %ghc_register_pkg and
> %ghc_preun_script to %ghc_unregister_pkg. I attach a little patch
> which shows the changes needed to macros.ghc and the templates.
I think at the same time we might as well drop the trivial %cabal_build and %cabal_haddock macros too.
Below is what macros.ghc looks like for me now. If this looks ok and there are no objections I would like to submit the revised packaging guidelines to the Packaging Committee for approval after the end of this week. If you could all take some moments to review https://fedoraproject.org/wiki/PackagingDrafts/Haskell this week that would be great.
I am building ghc-6.10.1-6.fc11 in koji with these changes so that we can test them.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 1287 bytes
Desc: not available
More information about the Fedora-haskell-list