[fedora-india] Tidbits of Problems

das das at randomink.org
Sat May 9 03:46:54 UTC 2009

I am pasting here my changed 10-synaptics.fdi that I have put in the
suggested place:

<?xml version="1.0" encoding="ISO-8859-1"?>

     This file will be overwritten with the next update. If you need to add
     custom options, copy the file into /etc/hal/fdi/policy/ first.

     See https://fedoraproject.org/wiki/Input_device_configuration -->

<deviceinfo version="0.2">
    <match key="info.capabilities" contains="input.touchpad">
        <!-- To add custom options for the touchpad, modify the examples below
             to suit your needs. The available options are listed in the
             "synaptics" man page. After modifyfing this file, you must
             restart HAL. Check the output of lshal whether your modifications
             have been merged successfully.

             Note: Options must always be type "string".
             The following examples enable left, right, middle clicks on
             single, double, triple finger tapping, respectively.

             <merge key="input.x11_options.TapButton1" type="string">1</merge>
             <merge key="input.x11_options.TapButton2" type="string">3</merge>
             <merge key="input.x11_options.TapButton3" type="string">2</merge>
	<merge key="input.x11_driver" type="string">synaptics</merge>
	<merge key="input.x11_options.TapButton1" type="string">1</merge>
	<merge key="input.x11_options.TapButton2" type="string">3</merge>
	<merge key="input.x11_options.VertEdgeScroll" type="boolean">1</merge>
	<merge key="input.x11_options.HorizEdgeScroll" type="boolean">1</merge>


After I put that changed file in /etc/hal/fdi/policy, I ran 'lshal'
that gave a lot of output, which was beyond my computer comprehension.
I was not sure how to restart hal and so as root I typed 'hald' and
pressed enter. The command prompt returned. But, because I was not
sure, I did reboot the system. I am giving you the results:

1. On the login prompt (the GUI one, initdefault is 5) tap is not
working. The click button below the touchpad is working.

2. In Xfce too tap is not working.

3. I opened a terminal and ran 'gnome-mouse-properties'. This has now
become a routine for me. The settings are all proper in it, I just
tapped on the icon of the bulb and it worked. Yes, the moment I run
this command, the command for gnome->mouse->properties, the tap starts

4. Now tap and scroll (H&V) are working. They will till re-login or reboot.

Do you think this is worth a bug-report? I can do it if you don't
think it is too trivial. In fact, I will copy and paste this mail
দাশ das

More information about the Fedora-india mailing list