Another Nvidia problem

Marc Williams marcw at
Fri Nov 7 17:34:14 UTC 2003

On Fri, 2003-11-07 at 11:20, Katherine Holcomb wrote:
> On Fri, 2003-11-07 at 11:45, Michael Anthony Porter wrote:
> > > none of the OpenGL screensavers work.  All fail with the error "Xlib: extension
> > > XFree86-DRI missing on display :0.0" (to be clear, this error occurred with the Nvidia-installed
> > > drivers as well as with the rpms).  Nvidia explicitly states that dri should *not*
> > > be loaded in XF86config and I did not do so for RH 9.0.  Everything
> > > worked fine under RH 9.0.  What has changed?
> > 
> > That's a common problem.  Have you tried doing "rpm -e --nodeps XFree86-Mesa-libGL-4.3.0-42"?  The NVIDIA files conflict with the default XFree86 ones, and if that RPM is installed, the default files are found instead of the NVidia provided ones.
> > 
> Since two people recommended it, I removed this rpm and reinstalled the
> kernel-module and nvidia-glx rpms.  After restarting X, when I tried my
> OpenGL screensavers (preview mode), instead of a black screen I got "No
> Preview Available."  So I removed Mesa-GLUT as well, reinstalled the
> Nvidia rpms again, and restarted X, all of which made things even worse
> because now I get " not found."  
> I can of course reinstall Mesa-GLUT, but something else is wrong with my
> configuration.  Any suggestions?

There was a different message
that said to just remove a couple files.  I did that and now I don't
receive that warning when running my xawtv.  Maybe try that instead of
removing Mesa altogether.

More information about the fedora-list mailing list