upgrade from test3: no graphical boot and weird fonts

Matthias Buelow mkb at mukappabeta.de
Fri Nov 7 02:52:22 UTC 2003

following up my own post with new results:

>* graphical boot no longer works (worked with test3)

apparently it's not enabled by default.  rc.sysconfig has changed
from test3, adding "rhgb" to the kernel arguments in grub.conf will
enable it.

>* some of the X11 Xft fonts (like Sans) are weird; they look "squashed" 
>vertically (i.e., are smaller than on test3, with the same fontsize 
>while vertical spacing seems to be the same as before).  I removed 
>.fonts-cache* in my homedir, to no avail.

apparently, this can be solved by running fc-cache as root.  maybe some
older fontconfig cache that hung around was messing things up.  if it
doesn't work, poking the font paths before running it (I added
<dir>/usr/X11R6/lib/X11/fonts/TTF</dir> to the local.conf in /etc/fonts)
might have an effect.  maybe it's also loading the lucida fonts from
there?  (don't know what exactly Sans and Monospace are aliases for...
the XML files for font configuration are a bit confusing to me.)

  Matthias Buelow;  mkb@{mukappabeta.de,informatik.uni-wuerzburg.de}

More information about the fedora-list mailing list