upgrade to fedora from 7.3

Jim Cornette redhat-jc at insight.rr.com
Sun Nov 9 05:01:45 UTC 2003

Bill Johnson wrote:
> I upgraded from RH8 to Fedora 1.0 with poor results.  Many things were 
> completely hosed, including grub, which seemed to have disappeared 
> entirely on my dual boot machine (I was no longer even given the boot 
> selection screen - it just booted directory into Fedora). Also, my eth0 
> connection was gone completely, with Fedora complaining that it my 3com 
> nic card was no where to be found. 

The latest thought on the 3COM NIC problem is related with the 
interaction of kudzu with the NIC. It appears to leave the NIC in a bad 
state after probing the NIC. I upgrade from RH7.3 to Severn1 and met 
with a totally messed up system. The clean install exhibited the same 

An earlier poster mentioned that starting the computer with kudzu off 
would allow his 3com to function normally. If he ran kudzu, it would 
foul up the card *big* *time* .

  Interestingly, when I booted into
> rescue mode using the Fedora install CDs, the nic card was there, so I 
> knew there was nothing wrong with either Fedora or the nic, but it had to 
> be with the upgrade.

I have my nic out right now for the "troubled" 3com. I might reinstall 
it, let kudzu detect the card, run setup to stop kudzu and then reboot. 
I want to see if I still get the "check cable" error that I used to get 
or if everything is as before.

> There were other issues, as well, but since I couldn't seem to get past 
> these 2, I ended up rerunning the install and choosing INSTALL instead of 
> UPGRADE.  I noticed that you can choose to NOT format the partitions (I 
> had not seen that before), and so I went that route, ending up with a 
> working Fedora 1.0 install and my existing data still intact.  
> So, my experience with upgrading using the UPGRADE option from the install 
> CD was a disaster, but so far the upgrade using the INSTALL option and not 
> formatting the partitions is working well.  The only thing I've noticed 
> so far is that my sound isn't working (always seems to be a problem), and 
> pine was not working.  I've fixed the latter, by simply doing an rpm -e 
> pine, and re-installing it.  
> Anybody else have input on installing without formatting the partitions?  
> Have I introduced any problems with this method that I should be aware of?

Sice you ran an install without formatting. I assume that the installer 
would go wild and overwrite whatever is in it's path. (no checks for 
what is already installed).
But since you stated that it seemed to leave most of your data intact, 
it might have left older binaries and configuration files around. This 
would leave you with a roulette type of install. You won't find out 
until you try out all of the programs on your system that you need/like 
to use.

> Bill Johnson
> "Call unto me, and I will answer thee, and shew thee great and 
> mighty things that thou knowest not."  Jeremiah 33:3
> On Fri, 7 Nov 2003, Leonard, Phil wrote:
>>>has anyone tried to upgrade redhat 7.3 to fedora 1.0? is it supported?
>>For that matter, has anyone upgraded from RH8.0 to FC1?  Did it work okay.

Your talents will be recognized and suitably rewarded.

More information about the fedora-list mailing list