nvidia 2d performance loss

Alex Helder devnull1 at att.net
Tue Nov 11 07:59:19 UTC 2003


Previously, I had RH 9, nvidia 1.0-4496 drivers, and kernel 2.4.22
(compiled by myself) and everything worked great (nice, stable, no

Now I am using Fedora Core 1, and I am experiencing an extreme 2d
performance loss. I am aware of the CC_COMPILER_MISMATCH and
Xfree86-Mesa-libGL issues, and these are resolved. FC 1 comes with the
same kernel ... 2.4.22 ... and just for the heck of it, I even compiled
my own to see if it would rectify the problem.

To get some kind of quantitative comparison, I created a 6 meg plain
text file (called "foo")

Then I did this :

1) Install "nv" driver
2) start X
3) open an xterm and maximize it
4) type "time cat foo"
5) Install the "nvidia" driver
repeat 2-4

Here are the results of dumping that 6 meg text file using "cat"

the "nv" driver 1 min and 2.5 seconds
the "nvidia" driver : 2 min and 47 sec.

I can't imagine the XFree86 "nv" driver being so much faster than
NVidia's own!

Here are some more specifics about my system:

Chipset: VIA 686B / VT82C693A/694x [Apollo PRO133x]
Card : GeForce4 MX-440
OS : Fedora Core 1
Drivers : 1.0-4496
Kernel 2.4.22 (of course)

Also :
(1) I am sure that the nvidia drivers are using AGP (according to lspci
-vv, the "nv" driver doesn't even enable AGP!)
(2) I am sure that I edited the XF86Config file correctly.
(3) I am aware of (and solved) the strange compiler mismatch and library
conflicts with XFree86-Mesa-libGL
(4) XFree86.0.log reports nothing unusual (no missing DRI symbols)

Thank you very much for any ideas

More information about the fedora-list mailing list