What the ...... ?????

Brian Fahrlander Brian at Fahrlander.net
Thu Nov 13 17:26:33 UTC 2003

On Wed, 2003-11-12 at 14:24, PatrickM wrote:
> I was hoping someone knew an answer or has a suggestion as to why 
> GLtron and Unreal Tournament aren't working (anymore)....
> For those who missed the first part: I installed GLtron and played 
> several games. Then I installed the demo of Unreal Tournament 2003 
> but when I started it, the screen went black and the desktop came 
> back up: no game!
> I tried UT2k3 several times, nothing. So I uninstalled it, no problems.
> But when trying to play GLtron, the games exits suddenly without any
>  message or so....
> Hopefully someone has some good thoughts, I'm stuck with this.
> For me, a Linux newbie, it might be better to go back to RH9???? What do you think?

    I just did an upgrade, and then later a full re-install.  I'm
running an NVidia card, and I found the trick on my setup, anyway. It
was about DRI, as far as I can tell.

    The 3d screensavers seemed to work ok, but Enemy Territory would
sometimes come up blank for no visible reason. Not all the time, and
sometimes when changing video settings, not just when starting.  

    I didn't try UT/UT2003, but I think the behaviour is the same.

    NVidia's DRI isn't the same as the standard DRI; I think it's
because they want to keep their own proprietary code to themselves. The
DRI website will tell you that NVidia doesn't HAVE a DRI, but whatever
the truth is, this seemed to fix mine- maybe it'll help yours, too.

    FIRST I got all the kernel-source and kernel development tools. Then
I downloaded the July 28th version (latest) of the NVidia drivers and
ran it with "--add-this-kernel".  This makes a new version of the
installer with the running kernel figured-in.

    Running this new installer, it worked like a charm!  I changed "nv"
to "nvidia" in the XF86Config file and 3D was working again, although
with the oddness of the black screen.

    The black-screen-dragon was killed when I actually _re-entered_ the
"Load 'dri'" line in the config file, and started it up.  Maybe it uses
a kind of DRI, maybe it doesn't.  But it works, and keeps working.

    If you're using another video card, well, all of this might have
been wasted.  :)

Brian Fahrländer                     Researcher, Conservative, and Technomad
Evansville, IN                                    http://Fahrlander.net
ICQ  5119262
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://listman.redhat.com/archives/fedora-list/attachments/20031113/6a878b66/attachment-0001.sig>

More information about the fedora-list mailing list