audacity seg fault

Steven P. Ulrick spu at
Sat Nov 15 01:06:10 UTC 2003

On Fri, 14 Nov 2003 18:21:49 -0600
Robert Brimhall <rbrimhal at> wrote:

> (audacity:13345): Gtk-CRITICAL **: file gtkaccellabel.c: line 213
> (gtk_accel_label_new): assertion `string != NULL' failed
> (audacity:13345): Gtk-CRITICAL **: file gtkmisc.c: line 210
> (gtk_misc_set_alignment): assertion `GTK_IS_MISC (misc)' failed
> (audacity:13345): Gtk-CRITICAL **: file gtkcontainer.c: line 947
> (gtk_container_add): assertion `GTK_IS_WIDGET (widget)' failed
> (audacity:13345): Gtk-CRITICAL **: file gtkaccellabel.c: line 399
> (gtk_accel_label_set_accel_widget): assertion `GTK_IS_ACCEL_LABEL
> (accel_label)' failed
> zsh: segmentation fault  audacity
> I get the above error when running the version from Freshrpms... what
> am I missing?

Hello, Everyone :)
I am running Fedora Core 1.  When I installed, I did a fresh install,
and I chose to install Everything.  I have also applied the two official
updates that have been released so far.
The reason I mention that is that I got exactly the same error that
Robert got.

I ran "apt-get update" and then "apt-get install -d audacity" and these
are the packages that I received as a result of those commands:

Like Robert asked, What am I missing?

Thanks in advance for your help :)
Steven P. Ulrick

P.S.: Also, I had been having a LOT of problems with Segmentation Faults with Fedora Core 1.  Ever since I removed "prelink" from /etc/cron.daily, I have not had any Segmentation Faults.  In a few days, I'm going to put "prelink" back where it belongs, to see once and for all if that has anything to do with all the Seg Faults people have been having.

Look at the statement that Ingo from Red Hat made in response to a previous post of mine:
> On Mon, 10 Nov 2003, Steven P. Ulrick wrote:
> > Hello, Everyone :)
> >    I was attracted to the subject line of this thread: "segmentation
> > faults galore"  With me it works this way: I'll compile a program from
> > source code: let's say Krusader, Krename or Juk.  Everything proceeds as
> > normal, and the applications in question work perfectly at first.  But
> > then, I don't know yet what it takes, maybe just a reboot, but then the
> > applications that had run fine maybe a boot ago, now bomb out with only
> > this error message: segmentation fault.
> hm, could this be prelink related?
> 	Ingo

More information about the fedora-list mailing list