Audacity package from freshrpms is broken ... solution

Jack Bowling jbinpg at
Sat Nov 15 08:38:09 UTC 2003

On Fri, Nov 14, 2003 at 11:09:41PM -0800, Jack Bowling wrote:
> On Sat, Nov 15, 2003 at 12:41:33AM -0600, Robert Brimhall wrote:
> > Just tried this with the wxgtk-devel package and I get the same error
> > and seg. fault.
> Weird. Here are some pertinent system specs:
> - I did an Everything FC1 install.
> - I downloaded and installed all the wxGTK* rpms off Matthias'
> site.
> That is essentially it. My first compile bombed with the pkg-config
> error. Then I installed the wxGTK-devel rpm and it completed
> successfully. I have not touched the prelink or exec-shield stock
> settings. Mind you I just finished a yum update of *58* released and
> testing packages so I do not have the same box now :))
> Luckily the static binary on the audacity sourceforge site should work
> for everybody.

ARRRGGGGHHH!!!! I forgot *the most important thing* for you to do:
add /usr/lib/pkgconfig to /etc/ and then run /sbin/ldconfig.
The configure script won't pick up the latest pkgconfig entries unless
pkgconfig is in the shared lib space. Do this and I bet your builds
start working. 

Jack Bowling
mailto: jbinpg at

More information about the fedora-list mailing list