apt-get, rpm y yum

Doncho N. Gunchev mr700 at globalnet.bg
Fri Nov 21 09:16:11 UTC 2003

On Thursday 20 November 2003 13:33, Artem B. Bityuckiy wrote:
> Panu Matilainen wrote:
> >On Thu, 2003-11-20 at 00:49, Francisco Roldan wrote:
> >>Thanks everybody for your answers on
> >>my Debian-Gentoo-Fedora email,
> >>I think I am almost decided to upgrade to Fedora.
> >>
> >>I have other question,
> >>I have worked with rpm since the
> >>old days of Red hat 6, now i
> >>am a little confuse with Fedora,
> >>I haven't installed yet, but i
> >>have read that there is a command
> >>'apt-get' ,  what is it ?
> >>and what about yum ?
> >>
> >>Can i keep usign rpm on Fedora Core 1 ?
> >
> >rpm hasn't gone anywhere, it's still the basic workhorse of package
> >management in Fedora (and RHL and RHEL for that matter).
> >
> >Yum, apt and up2date are smart frontends to rpm which resolve package
> >dependencies for you, can upgrade the whole system from one version to
> >another etc.
> >
> >	- Panu -
> I often heard word "smart" about up2date. The example from reality: In
> RH9 up2date downloaded new packages and offer KDE user to update system.
> User answers - yes. After update system can't work and can't boot. I
> don't know exactly what happened, but up2date tried to update glibc and
> hanged on this - and this is normal because libc is used everywhere. Why
> up2date is "smart" if it is so stupid to update glibc while KDE and a
> lot of other applications are running?
    It worked many times for me, I just see 'init reloading' after this.
The problem here seems to be that rpm has locked (yes :( there's bug) and
the only option you have is to use the install CD in rescue mode, chrooot
and rpm -Uhv --force glibc-* from the CD after rm -rf /var/lib/rmp/__db*;

  Doncho N. Gunchev

More information about the fedora-list mailing list