REPOST: Problem with i810 soundcard and AC 97 codec combo

Mike Klinke lsomike at
Mon Nov 24 03:13:10 UTC 2003

On Friday 21 November 2003 20:24, Kojiro Dracomour wrote:
> > I suppose my post got drowned in a slew of others,
> > so
> > I'm just reposting it. No problem.
> -----------------------------------------------------
> > Ok, I did a little research before posting this.
> >
> > Often I will get a message when trying to play sound
> > of some kind that "Cannot open /dev/dsp: Device or
> > Resource is busy". I'm using aRts. When I boot up,
> > before anything else happens, no applications
> > loaded,
> > my soundcard is already occupied and I get this
> > message. IF I am in KDE, and only KDE so far to my
> > knowledge as I haven't really tested elsewhere, if I
> > type in the command prompt "killall artsd", switch
> > XMMS to OSS Driver, it works. However if I disable
> > aRts on KDE boot, that trick doesn't work, in fact
> > no
> > sound works. Same with WMaker. I haven't tried to
> > see
> > if sound will work on init 3 yet.
> >
> > Anyway, my research shows that this "bug", as it was
> > put, was in the kernell for RedHat 7.3 but fixed for
> > RedHat 8.0.
> ------------------------------------------------------
> > I want to know if anyone is having similar problems.
> > Is this a kernel bug? Is there something I did wrong
> > but didn't notice? Is there a known fix?
> >
> > Recent update: I noticed my CD player works fine and
> > has worked fine since straight install. If I do
> > above
> > trick and kill  artsd, I can play the CD player and
> > sound will work normally.
> >

I sent this a couple of days ago but it seems the list processor went on 
vacation for a bit.  Hope it's not a duplicate ....
Like you, I get the "Cannot open /dev/dsp" message when aRts is enabled 
in the control center.  However, when I disable it so it doesn't start 
up on boot, I have sound; e.g. "play <somefile.wav>."  Mind you, I'm 
probably not a real good person to ask as I find sound on a computer 
more anoying than not so I don't really test that aspect very well but 
for the few things I do use it for disabling aRts seems to work.

This is a Sony VAIO laptop with the i810 chip set.

04:07:09 # lspci
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio 
(rev 03)
04:07:15 # lsmod
Module                  Size  Used by    Not tainted
i810_audio             27752   1  (autoclean)
ac97_codec             17192   0  (autoclean) [i810_audio]
soundcore               6468   2  (autoclean) [i810_audio]

Regards,  Mike Klinke

More information about the fedora-list mailing list