fedora will not access dhcp server to get IP

Ken Chamberlain ken.chamberlain at utoronto.ca
Mon Nov 24 16:26:00 UTC 2003

On Mon, 2003-11-24 at 9:55, Chris Kloiber wrote:
> Message: 9
> Subject: Re: fedora will not access dhcp server to get IP
> From: Chris Kloiber <ckloiber at redhat.com>
> To: fedora-list at redhat.com
> Organization: Red Hat, Inc.
> Date: Mon, 24 Nov 2003 12:20:52 +0800
> Reply-To: fedora-list at redhat.com
> On Mon, 2003-11-24 at 09:55, Trevor Smith wrote:
> > I have had the same hardware and installed various versions of (red
> > hat) linux many times over the past years. It has always autodetected
> > all my hardware and autoconnected to my Internet provider. Originally
> > my local cable company using DHCP then my local phone company (ADSL)
> > also using DHCP. At no time did I ever configure any networking, I
> just
> > told whatever version of red hat to use DHCP and we were off. 
> > 
> > I hadn't been using linux much but now I'm enrolled in computer
> science
> > and wanted to stop using Win2k so thought I'd install a newer version
> > of everything but suddenly I have no ability to connect to the
> network.
> > Again, no hardware has changed -- except I did install 256 meg more
> > RAM. The ADSL "modem" has remained connected, the nic is the same,
> > everything is exactly as it was, where it was. Win2k continues to
> > access my ADSL connection 100% of the time. 
> > 
> > I installed Fedora core 1 and, as usual, the installation was flawless
> > -- except after install, there is no connection to the DHCP server. At
> > boot it says 'bringing up eth0...' then a line about failing to get ip
> > settings or something. Trying to get eth0 to work after boot is
> > similarly useless. It waits for approx 1 minute each time then says
> > "failed". 
> > 
> > I have reinstalled 6 or 7 times with different strategies, but no
> > different results. I tried a SuSE network install, but it also fails
> to
> > get any sort of connection (but that may be because I have no idea
> what
> > "parameters", if any, are needed for the nic. 
> > 
> > Interestingly, I tried reinstalling Red Hat 7.2 and it did not set up
> > my nic properly but this is NOT the problem with Fedora and SuSE. BOTH
> > are identifying my nic properly and fedora, at least, installs the
> > "proper" driver. The nic is a D-Link but it has always been identified
> > as a DEC 21x4x based card. I even took the damn thing out to read the
> > chip numbers to make sure I wasn't remembering it wrong. (And I
> > *wasn't* remembering wrong.) 
> The DEC 21x4x uses a 'tulip' driver, in older distributions the driver
> may have been 'de4x5', depending on the age of the card.
> > So I "rebooted" the "modem" by unplugging it, hoping to get new IP
> > leases, or whatever. No change. Win2k still works perfectly, linux
> > still fails to contact anything when first attempting to find the dhcp
> > server. 
> > 
> > btw, l0 works fine (i can ping 
> You don't even need a network card for to work.
> > there seems to be no dhcpcd or pump on fedora, but i did find that
> > dhclient works from the terminal but that has the same results as
> > attempting to use the graphical interface to "start" eth0. Except with
> > dhclient I get many lines of output while the minute elapses and
> before
> > I get the error saying no DHCP offers were received. Basically it says
> > it's sending a request, then another, then another, etc. No response,
> > then it times out. 
> > 
> > btw, Win2k (and OS/2 before it, and various red hats before it) never
> > wait(ed) any amount of time to get their DHCP IPs. It happens in a few
> > seconds, not in a minute or more. 
> > 
> > ifconfig shows everything "working. There is an entry for l0 and one
> > for eth0 with all kinds of info for each, but no IP for eth0 (of
> > course). I'm going on memory here since this has been an oddysey for 3
> > days and the only net connection I have is from win2k. 
> Does the end of the eth0 section show a line indicating the
> "Interrupt:XX"? If not, set your bios for a "Non-PnP" OS.
> > I read somewhere there was some bug and "fix" about requiring a
> > hostname of *any* kind to get eth0 working but I tried that and it
> > changed nothing. (In fact, the symptoms I read about didn't seem to be
> > happening on my machine, but I thought I'd try anyway.) 
> > 
> > I saw on my win2k system the IRQ of the network card was 9 but fedora
> > was trying to say it was 10 so I tried to change it to 9 to see what
> > would happen but nothing did. I'm not really sure how to change an
> IRQ.
> > I just went to the nic entry in some networking tool in the Gnome gui
> > somewhere and changed the drop down list for the nic's IRQ from
> > "unknown" to "9" and rebooted. no joy. 
> > 
> > I read some networking howto and got some vague ideas about things to
> > try but none did anything. 
> > 
> > I know I'm not providing much technical detail here but I can't
> > remember some and don't know what all would be needed to diagnose
> > anyway. 
> > 
> > So, summary: 
> > 
> > - the nic is recognized and a driver is installed and it appears to
> > work. 
> > - the adsl 'modem' works for sure since Win2k continues to connect 
> > - the attempt to find the dhcp server at my phone company and get an
> ip
> > address for eth0 fails 100% of the time in linux 
> > 
> > Question: 
> > 
> > where do I look next? What do I try and how do I try it? What
> > information do I try to extract from those attempts? How do I apply
> > that information (if acquired) to fix this damn thing? 
> > 
> > Thanks for the patience
In a adsl network setup, there IS no eth0 interface.  My RHL 8 clean
install incorrectly assumed the detected ethernet device was part of a
local area network.  Perhaps this has happened to you.  Disable this
interface (eth0) if it isn't already.  Then set-up a ppp0 interface via
Internet Connection Wizard. Device type should be xDSL.  Ethernet
device=ent0, ISP provider=ppp0 (if you want it to auto start
networking).  Provide userid and password.  A tip:some userid's should
be specified as userid at domain. 

Ken Chamberlain <ken.chamberlain at utoronto.ca>
University of Toronto

More information about the fedora-list mailing list