laptop acpi

Dan Goodes fedora-list at
Wed Nov 26 00:55:27 UTC 2003

ACPI is not fully supported on all systems. E.g. I get the Battery applet 
working fine on my HP/Compaq Presario 2133, and I can cat 
/proc/acpi/thermal_zone/THRM/temprature to get the current system/cpu 
temp, but things like suspect/hibernate don't work yet.

you could try the swsusp (software suspend) package, tho I've never tried 
it so I can't vouch for its usefullness.


On Wed, 26 Nov 2003, Simon Bell wrote:

> Hi
> I have a Sharp PC-FS2518 laptop. In order to get the battery meter applet
> working i enabled acpi in grub and it appears to be working. Shutting the
> laptop appears to trigger the screen off etc, so i assume acpi is working in
> at least some ways. However, i cant seem to make it suspend. Ive tried the
> echo 3 > /proc/acpi/sleep command, but nothing at all happens. The only
> command that works in this way is echo 5, which appears to immediately cut
> the power to the laptop. Is there an easy way to get these things to work
> properly?
> thanks
> Simon


Dan Goodes  :  Systems Programmer  :  dang at

Help support PlanetMirror - Australia's largest Internet archive
by signing up for PlanetMirror Premium :

More information about the fedora-list mailing list